Please Read First
Troubleshooting Tips
Frequently Asked Questions
Note: Appearance issues are often caused by caching plugins.
When Posting Please Include Your URL.
Search Forum Using Google Search Box Above
IMPORTANT: If after forum login, you appear logged out, click on "New Posts". You should show as logged in then. It's a Vbulletin bug.
Forum Video

Results 1 to 8 of 8
  1. #1
    Join Date
    Dec 2010
    Posts
    4
    Rep Power
    0

    Default 'curl-init()' Problem on local server - How I solved it

    Hi,

    I'm not sure whether it would be silly to post this here, but since I had this problem and was able to solve it, I thought I might as well let others know.

    I decided to test Socrates on a local installation first (i.e. on http://localhost running on my laptop - I'm using WAMPSERVER 2.0 on Windows XP SP2).

    When I clicked on the Socrates Theme Control Section right after installation, I was asked to Activate my copy. I put in the code that was provided to me, and I got this Error message - "Call to undefined function: curl_init() ......."...!!!

    Oh !!!! What to do ??? ......What was happening ...???...

    After looking around a bit, I found that the "php_curl" extension on my Wampserver 2.0 was not running (it was not checked). I checked it, then reloaded (refreshed) the Socrates admin page - and lo - it was working.

    This is how to do it, in case you are wondering - if you are running Wampserver 2.0 on Windows XP SP2, left-click on the Wampserver icon in the system-tray (the little tray at the very bottom-right of your screen - where you have your time and internet connection and data transfer icons). On the menu that comes up, go to PHP -> PHP EXTENSIONS -> and click on "php_curl" on the long menu that comes up. Allow a few seconds (or maybe a minute) for the changes to take place (you'll notice the Wampserver icon turn orange(-ish) and then back to white again - that's when the Changes are complete). After that simply refresh the Socrates Admin page that is open in your browser - and you should be set.

    Guess if this happens on an online installation, you'll have to speak to your Hosting Provider to turn on the php-curl extension on their php installation.

    Hope this helps.

    Thanks.
    Last edited by samidhranjan; 12-01-2010 at 08:08 AM.

  2. #2
    Join Date
    Jun 2010
    Posts
    4
    Rep Power
    0

    Default

    Yes this helps, just got the error for the first time. Thanks for the tip

  3. #3
    Join Date
    Jun 2010
    Posts
    15
    Rep Power
    0

    Default

    Thanks for guidance on this. The process for enabling the "php_curl" extension is a little different for XAMPP users - here's a brief explanation I found: -

    Just 3 easy steps.

    1. Locate and open your php.ini file (if not sure open the url http://localhost/xampp/phpinfo.php, and search for the line Loaded Configuration File). Mine was in C:\xampp\php\php.ini.
    2. Near line 952, uncomment extension=php_curl.dll (remove the semicolon).
    3. Restart the Apache web server.


    Now you should be able to use cURL PHP extension with XAMPP on Windows.

  4. #4
    Join Date
    Feb 2012
    Posts
    1
    Rep Power
    0

    Default

    Works perfect!
    Thanks,
    Sonny

  5. #5
    Join Date
    Jan 2012
    Posts
    957
    Rep Power
    5

    Default

    Thank you. We always welcome tips like this.
    Leilani Clifford
    - Forum Admin

    ----------------------------
    We're building our Socrates Facebook community! Come visit us, and Like us to stay up to date on everything Socrates
    Facebook: http://www.facebook.com/socrateswptheme
    Twitter: http://www.twitter.com/socratestheme

  6. #6
    Join Date
    Jun 2010
    Posts
    5
    Rep Power
    0

    Default

    Hi guys, I'm using Xampp on Vista and have tried the fix given above but it's not working. I have 2 files: php.ini-development and php.ini-production. I've removed the semicolon from both, restarted Apache, cleared my browser cache, no joy. Any ideas?

    Thanks

  7. #7
    Join Date
    Jun 2010
    Posts
    5
    Rep Power
    0

    Default

    Aha, I found another file! It's working now, thanks for the info above.

  8. #8
    Join Date
    Jun 2010
    Posts
    15
    Rep Power
    0

    Default

    Quote Originally Posted by sharoni View Post
    Aha, I found another file! It's working now, thanks for the info above.
    Glad you got it working, I was just starting to scratch my head

Similar Threads

  1. Socrates for Local Business Sites?
    By GeneC in forum Feature Requests
    Replies: 3
    Last Post: 11-17-2010, 02:44 PM
  2. 500 Internal Server Error Workaround no working
    By mlmarchitect in forum Official Support 3.0
    Replies: 1
    Last Post: 07-27-2010, 12:45 PM
  3. 500 Internal Server Error
    By GillionaireG in forum Bug Reporting and Fixes
    Replies: 6
    Last Post: 07-18-2010, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •